package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?i)([A-Z0-9._%+-]+@[A-Z0-9.-]+\.[A-Z]{2,4})|([5-6][0-9]{6})`)
var str = `Ralph Bakhuis, 4657758, 5205734 (ralphbakhuis@gmail.com)`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}