$re = '/([A-Z0-9._%+-]+@[A-Z0-9.-]+\.[A-Z]{2,4})|([5-6][0-9]{6})/i';
$str = 'Ralph Bakhuis, 4657758, 5205734 (ralphbakhuis@gmail.com)';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);