const regex = /([A-Z0-9._%+-]+@[A-Z0-9.-]+\.[A-Z]{2,4})|([5-6][0-9]{6})/gi;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('([A-Z0-9._%+-]+@[A-Z0-9.-]+\\.[A-Z]{2,4})|([5-6][0-9]{6})', 'gi')
const str = `Ralph Bakhuis, 4657758, 5205734 (ralphbakhuis@gmail.com)`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}