import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "([A-Z0-9._%+-]+@[A-Z0-9.-]+\\.[A-Z]{2,4})|([5-6][0-9]{6})";
final String string = "Ralph Bakhuis, 4657758, 5205734 (ralphbakhuis@gmail.com)";
final Pattern pattern = Pattern.compile(regex, Pattern.CASE_INSENSITIVE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}