use strict;
my $str = '"Name","Period","Data"
"App - NA, 11002, Project - NA, FY22, Working, USD, Budget, 640605","Jan","171.4"
"App - NA, 11002, Project - NA, FY22, Working, USD, Budget, 640605","Feb","171.8"';
my $regex = qr/(?<!"),\s*(?!")/mp;
my $subst = '","';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";