$re = '/(?<!"),\s*(?!")/m';
$str = '"Name","Period","Data"
"App - NA, 11002, Project - NA, FY22, Working, USD, Budget, 640605","Jan","171.4"
"App - NA, 11002, Project - NA, FY22, Working, USD, Budget, 640605","Feb","171.8"';
$subst = "\",\"";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;