# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"(?<!\"),\s*(?!\")"
test_str = ("\"Name\",\"Period\",\"Data\"\n"
"\"App - NA, 11002, Project - NA, FY22, Working, USD, Budget, 640605\",\"Jan\",\"171.4\"\n"
"\"App - NA, 11002, Project - NA, FY22, Working, USD, Budget, 640605\",\"Feb\",\"171.8\"")
subst = "\",\""
# You can manually specify the number of replacements by changing the 4th argument
result = re.sub(regex, subst, test_str, 0, re.MULTILINE)
if result:
print (result)
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.