re = /(?<!"),\s*(?!")/m
str = '"Name","Period","Data"
"App - NA, 11002, Project - NA, FY22, Working, USD, Budget, 640605","Jan","171.4"
"App - NA, 11002, Project - NA, FY22, Working, USD, Budget, 640605","Feb","171.8"'
subst = '","'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result