#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?mx)^(?!=>)(?:(?!=>$)(?:[-\w]|=>))+$"
Local $sString = "Field_name_true2" & @CRLF & _
"abc=>d" & @CRLF & _
"=>abc" & @CRLF & _
"abc=>abc" & @CRLF & _
"somewhere_over_the_ocean=>" & @CRLF & _
"somewhere_over_the_ocean=>dda" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")