re = /^(?!=>)(?:(?!=>$)(?:[-\w]|=>))+$/mx
str = 'Field_name_true2
abc=>d
=>abc
abc=>abc
somewhere_over_the_ocean=>
somewhere_over_the_ocean=>dda
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end