using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(?!=>)(?:(?!=>$)(?:[-\w]|=>))+$";
string input = @"Field_name_true2
abc=>d
=>abc
abc=>abc
somewhere_over_the_ocean=>
somewhere_over_the_ocean=>dda
";
RegexOptions options = RegexOptions.Multiline | RegexOptions.IgnorePatternWhitespace;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}