import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(?!=>)(?:(?!=>$)(?:[-\\w]|=>))+$";
final String string = "Field_name_true2\n"
+ "abc=>d\n"
+ "=>abc\n"
+ "abc=>abc\n"
+ "somewhere_over_the_ocean=>\n"
+ "somewhere_over_the_ocean=>dda\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE | Pattern.COMMENTS);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}