import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(url|href|src)\\s*[=\\(]\\s*(['\"][^'\"]+['\"]|[^\\s\\)]+)(?=(\\/?>|\\s*\\)))?";
final String string = "url(wp-content/plugins/accordions/assets/global/webfonts/fa-brands-400.woff)\n"
+ "url(\"wp-content/plugins/accordions/assets/global/webfonts/fa-brands-400.woff\")\n"
+ "url('wp-content/plugins/accordions/assets/global/webfonts/fa-brands-400.woff')\n"
+ "url ( wp-content/plugins/accordions/assets/global/webfonts/fa-brands-400.woff )\n"
+ "url ( \"wp-content/plugins/accordions/assets/global/webfonts/fa-brands-400.woff\" )\n"
+ "url ( 'wp-content/plugins/accordions/assets/global/webfonts/fa-brands-400.woff' )\n\n"
+ "url(wp-content/plugins/accordions/assets/global/webfonts/fa-brands-400.woff)\n"
+ "url(\"wp-con)tent/plugins/accordions/assets/global/webfonts/fa-brands-400.woff\")\n"
+ "url('wp-cont)ent/plugins/accordions/assets/global/webfonts/fa-brands-400.woff')\n"
+ "url ( wp-content/plugins/accordions/assets/global/webfonts/fa-brands-400.woff )\n"
+ "url ( \"wp-con)tent/plugins/accordions/assets/global/webfonts/fa-brands-400.woff\" )\n"
+ "url ( 'wp-cont)ent/plugins/accordions/assets/global/webfonts/fa-brands-400.woff' )\n"
+ "-------\n"
+ "<link rel='stylesheet' id='base-css' href='wp-content/themes/biopic/stylesheets/base.css?ver=5.1.2' type='text/css' media='all' />\n"
+ "<link rel='stylesheet' id='base-css' href=\"wp-content/themes/biopic/stylesheets/base.css?ver=5.1.2\" type='text/css' media='all' />\n"
+ "<link rel='stylesheet' id='base-css' href=wp-content/themes/biopic/stylesheets/base.css?ver=5.1.2 type='text/css' media='all' />\n"
+ "<link rel='stylesheet' id='base-css' href = 'wp-content/themes/biopic/stylesheets/base.css?ver=5.1.2' type='text/css' media='all' />\n"
+ "<link rel='stylesheet' id='base-css' href = \"wp-content/themes/biopic/stylesheets/base.css?ver=5.1.2\" type='text/css' media='all' />\n"
+ "<link rel='stylesheet' id='base-css' href = wp-content/themes/biopic/stylesheets/base.css?ver=5.1.2 type='text/css' media='all' />\n\n"
+ "<link rel='stylesheet' id='base-css' href='wp-content/themes/biopic/stylesheets/base.css?ver=5.1.2'/>\n"
+ "<link rel='stylesheet' id='base-css' href=\"wp-content/themes/biopic/stylesheets/base.css?ver=5.1.2\"/>\n"
+ "<link rel='stylesheet' id='base-css' href=wp-content/themes/biopic/stylesheets/base.css?ver=5.1.2/>\n"
+ "<link rel='stylesheet' id='base-css' href = 'wp-content/themes/biopic/stylesheets/base.css?ver=5.1.2'/>\n"
+ "<link rel='stylesheet' id='base-css' href = \"wp-content/themes/biopic/stylesheets/base.css?ver=5.1.2\"/>\n"
+ "<link rel='stylesheet' id='base-css' href = wp-content/themes/biopic/stylesheets/base.css?ver=5.1.2 />";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}