use strict;
my $str = 'url(wp-content/plugins/accordions/assets/global/webfonts/fa-brands-400.woff)
url("wp-content/plugins/accordions/assets/global/webfonts/fa-brands-400.woff")
url(\'wp-content/plugins/accordions/assets/global/webfonts/fa-brands-400.woff\')
url ( wp-content/plugins/accordions/assets/global/webfonts/fa-brands-400.woff )
url ( "wp-content/plugins/accordions/assets/global/webfonts/fa-brands-400.woff" )
url ( \'wp-content/plugins/accordions/assets/global/webfonts/fa-brands-400.woff\' )
url(wp-content/plugins/accordions/assets/global/webfonts/fa-brands-400.woff)
url("wp-con)tent/plugins/accordions/assets/global/webfonts/fa-brands-400.woff")
url(\'wp-cont)ent/plugins/accordions/assets/global/webfonts/fa-brands-400.woff\')
url ( wp-content/plugins/accordions/assets/global/webfonts/fa-brands-400.woff )
url ( "wp-con)tent/plugins/accordions/assets/global/webfonts/fa-brands-400.woff" )
url ( \'wp-cont)ent/plugins/accordions/assets/global/webfonts/fa-brands-400.woff\' )
-------
<link rel=\'stylesheet\' id=\'base-css\' href=\'wp-content/themes/biopic/stylesheets/base.css?ver=5.1.2\' type=\'text/css\' media=\'all\' />
<link rel=\'stylesheet\' id=\'base-css\' href="wp-content/themes/biopic/stylesheets/base.css?ver=5.1.2" type=\'text/css\' media=\'all\' />
<link rel=\'stylesheet\' id=\'base-css\' href=wp-content/themes/biopic/stylesheets/base.css?ver=5.1.2 type=\'text/css\' media=\'all\' />
<link rel=\'stylesheet\' id=\'base-css\' href = \'wp-content/themes/biopic/stylesheets/base.css?ver=5.1.2\' type=\'text/css\' media=\'all\' />
<link rel=\'stylesheet\' id=\'base-css\' href = "wp-content/themes/biopic/stylesheets/base.css?ver=5.1.2" type=\'text/css\' media=\'all\' />
<link rel=\'stylesheet\' id=\'base-css\' href = wp-content/themes/biopic/stylesheets/base.css?ver=5.1.2 type=\'text/css\' media=\'all\' />
<link rel=\'stylesheet\' id=\'base-css\' href=\'wp-content/themes/biopic/stylesheets/base.css?ver=5.1.2\'/>
<link rel=\'stylesheet\' id=\'base-css\' href="wp-content/themes/biopic/stylesheets/base.css?ver=5.1.2"/>
<link rel=\'stylesheet\' id=\'base-css\' href=wp-content/themes/biopic/stylesheets/base.css?ver=5.1.2/>
<link rel=\'stylesheet\' id=\'base-css\' href = \'wp-content/themes/biopic/stylesheets/base.css?ver=5.1.2\'/>
<link rel=\'stylesheet\' id=\'base-css\' href = "wp-content/themes/biopic/stylesheets/base.css?ver=5.1.2"/>
<link rel=\'stylesheet\' id=\'base-css\' href = wp-content/themes/biopic/stylesheets/base.css?ver=5.1.2 />';
my $regex = qr/(url|href|src)\s*[=\(]\s*(['"][^'"]+['"]|[^\s\)]+)(?=(\/?>|\s*\)))?/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}