# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"(url|href|src)\s*[=\(]\s*(['\"][^'\"]+['\"]|[^\s\)]+)(?=(\/?>|\s*\)))?"
test_str = ("url(wp-content/plugins/accordions/assets/global/webfonts/fa-brands-400.woff)\n"
"url(\"wp-content/plugins/accordions/assets/global/webfonts/fa-brands-400.woff\")\n"
"url('wp-content/plugins/accordions/assets/global/webfonts/fa-brands-400.woff')\n"
"url ( wp-content/plugins/accordions/assets/global/webfonts/fa-brands-400.woff )\n"
"url ( \"wp-content/plugins/accordions/assets/global/webfonts/fa-brands-400.woff\" )\n"
"url ( 'wp-content/plugins/accordions/assets/global/webfonts/fa-brands-400.woff' )\n\n"
"url(wp-content/plugins/accordions/assets/global/webfonts/fa-brands-400.woff)\n"
"url(\"wp-con)tent/plugins/accordions/assets/global/webfonts/fa-brands-400.woff\")\n"
"url('wp-cont)ent/plugins/accordions/assets/global/webfonts/fa-brands-400.woff')\n"
"url ( wp-content/plugins/accordions/assets/global/webfonts/fa-brands-400.woff )\n"
"url ( \"wp-con)tent/plugins/accordions/assets/global/webfonts/fa-brands-400.woff\" )\n"
"url ( 'wp-cont)ent/plugins/accordions/assets/global/webfonts/fa-brands-400.woff' )\n"
"-------\n"
"<link rel='stylesheet' id='base-css' href='wp-content/themes/biopic/stylesheets/base.css?ver=5.1.2' type='text/css' media='all' />\n"
"<link rel='stylesheet' id='base-css' href=\"wp-content/themes/biopic/stylesheets/base.css?ver=5.1.2\" type='text/css' media='all' />\n"
"<link rel='stylesheet' id='base-css' href=wp-content/themes/biopic/stylesheets/base.css?ver=5.1.2 type='text/css' media='all' />\n"
"<link rel='stylesheet' id='base-css' href = 'wp-content/themes/biopic/stylesheets/base.css?ver=5.1.2' type='text/css' media='all' />\n"
"<link rel='stylesheet' id='base-css' href = \"wp-content/themes/biopic/stylesheets/base.css?ver=5.1.2\" type='text/css' media='all' />\n"
"<link rel='stylesheet' id='base-css' href = wp-content/themes/biopic/stylesheets/base.css?ver=5.1.2 type='text/css' media='all' />\n\n"
"<link rel='stylesheet' id='base-css' href='wp-content/themes/biopic/stylesheets/base.css?ver=5.1.2'/>\n"
"<link rel='stylesheet' id='base-css' href=\"wp-content/themes/biopic/stylesheets/base.css?ver=5.1.2\"/>\n"
"<link rel='stylesheet' id='base-css' href=wp-content/themes/biopic/stylesheets/base.css?ver=5.1.2/>\n"
"<link rel='stylesheet' id='base-css' href = 'wp-content/themes/biopic/stylesheets/base.css?ver=5.1.2'/>\n"
"<link rel='stylesheet' id='base-css' href = \"wp-content/themes/biopic/stylesheets/base.css?ver=5.1.2\"/>\n"
"<link rel='stylesheet' id='base-css' href = wp-content/themes/biopic/stylesheets/base.css?ver=5.1.2 />")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.