#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)(\$array\[)([^\]]+)(\])"
Local $sString = "$array[search], $array[test2]"
Local $sSubst = "\1'\2'\3"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)