package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(\$array\[)([^\]]+)(\])`)
var str = `$array[search], $array[test2]`
var substitution = "\1'\2'\3"
fmt.Println(re.ReplaceAllString(str, substitution))
}