use strict;
my $str = '$array[search], $array[test2]';
my $regex = qr/(\$array\[)([^\]]+)(\])/mp;
my $subst = '\\1\'\\2\'\\3';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";