import Foundation
let pattern = #"(\$array\[)([^\]]+)(\])"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"$array[search], $array[test2]"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"\1'\2'\3"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)