import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^[\\n\\s]*(\\w+)[\\S\\s:]";
final String string = "Revert \"refactor (REC-105): Use v-deep instead of /deep/\n"
+ "refactor: blah\n"
+ "refactor (abc-123): blah\n"
+ "some random garbage refactor (abc-123): blah";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}