const regex = /^[\n\s]*(\w+)[\S\s:]/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^[\\n\\s]*(\\w+)[\\S\\s:]', 'gm')
const str = `Revert "refactor (REC-105): Use v-deep instead of /deep/
refactor: blah
refactor (abc-123): blah
some random garbage refactor (abc-123): blah`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}