import re
regex = re.compile(r"^[\n\s]*(\w+)[\S\s:]", flags=re.MULTILINE)
test_str = ("Revert \"refactor (REC-105): Use v-deep instead of /deep/\n"
"refactor: blah\n"
"refactor (abc-123): blah\n"
"some random garbage refactor (abc-123): blah")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")