use strict;
my $str = 'Revert "refactor (REC-105): Use v-deep instead of /deep/
refactor: blah
refactor (abc-123): blah
some random garbage refactor (abc-123): blah';
my $regex = qr/^[\n\s]*(\w+)[\S\s:]/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}