#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "#[-_a-zA-Z][_a-zA-Z0-9-]*(?=[^}]*\{)"
Local $sString = "#foo-bar {" & @CRLF & _
" color: #f00;" & @CRLF & _
"}" & @CRLF & _
"" & @CRLF & _
"#bar .foo {" & @CRLF & _
" font-weight: bold;" & @CRLF & _
"}" & @CRLF & _
"" & @CRLF & _
".baz #bar {" & @CRLF & _
" display: block;" & @CRLF & _
"}" & @CRLF & _
"" & @CRLF & _
".foo {" & @CRLF & _
" color: #f00; // Yikes!" & @CRLF & _
"" & @CRLF & _
" .bar {" & @CRLF & _
" color: blue;" & @CRLF & _
" }" & @CRLF & _
"}"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")