re = /#[-_a-zA-Z][_a-zA-Z0-9-]*(?=[^}]*\{)/
str = '#foo-bar {
color: #f00;
}
#bar .foo {
font-weight: bold;
}
.baz #bar {
display: block;
}
.foo {
color: #f00; // Yikes!
.bar {
color: blue;
}
}'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end