$re = '/#[-_a-zA-Z][_a-zA-Z0-9-]*(?=[^}]*\{)/';
$str = '#foo-bar {
color: #f00;
}
#bar .foo {
font-weight: bold;
}
.baz #bar {
display: block;
}
.foo {
color: #f00; // Yikes!
.bar {
color: blue;
}
}';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);