using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"#[-_a-zA-Z][_a-zA-Z0-9-]*(?=[^}]*\{)";
string input = @"#foo-bar {
color: #f00;
}
#bar .foo {
font-weight: bold;
}
.baz #bar {
display: block;
}
.foo {
color: #f00; // Yikes!
.bar {
color: blue;
}
}";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}