using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\b(?<![0-9-])(\d+)(?![0-9-])\b";
string input = @"max-3 cvd-19 agent-007 8-zoo 2ab c3d ef4 55g h66i jk77
8m9n o0p2 million 0 22 333 4444
";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}