re = /\b(?<![0-9-])(\d+)(?![0-9-])\b/m
str = 'max-3 cvd-19 agent-007 8-zoo 2ab c3d ef4 55g h66i jk77
8m9n o0p2 million 0 22 333 4444
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end