const regex = /\b(?<![0-9-])(\d+)(?![0-9-])\b/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\b(?<![0-9-])(\\d+)(?![0-9-])\\b', 'gm')
const str = `max-3 cvd-19 agent-007 8-zoo 2ab c3d ef4 55g h66i jk77
8m9n o0p2 million 0 22 333 4444
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}