import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\b(?<![0-9-])(\\d+)(?![0-9-])\\b";
final String string = "max-3 cvd-19 agent-007 8-zoo 2ab c3d ef4 55g h66i jk77 \n"
+ "8m9n o0p2 million 0 22 333 4444 \n\n\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}