import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "<a .*?href=(['\"]?).*?\\/?download.aspx\\?myid=\\{?([0-9a-f]{8}-?[0-9a-f]{4}-?[0-9a-f]{4}-?[0-9a-f]{4}-?[0-9a-f]{12})\\}?\\1.*?>(.*?)<\\/a>";
final String string = "<a clicktracking=off href=\"https://www.test.com/1.pdf\">test</a><br />Test<br />Test</div><br><div> </div><br><div><a clicktracking=off href=\"download.aspx?myID=11111111-2222-3333-4444-555555555555\">Teet.docx</a></div>";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE | Pattern.CASE_INSENSITIVE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}