const regex = /<a .*?href=(['"]?).*?\/?download.aspx\?myid=\{?([0-9a-f]{8}-?[0-9a-f]{4}-?[0-9a-f]{4}-?[0-9a-f]{4}-?[0-9a-f]{12})\}?\1.*?>(.*?)<\/a>/gmi;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('<a .*?href=([\'"]?).*?\\\/?download.aspx\\?myid=\\{?([0-9a-f]{8}-?[0-9a-f]{4}-?[0-9a-f]{4}-?[0-9a-f]{4}-?[0-9a-f]{12})\\}?\\1.*?>(.*?)<\\\/a>', 'gmi')
const str = `<a clicktracking=off href="https://www.test.com/1.pdf">test</a><br />Test<br />Test</div><br><div> </div><br><div><a clicktracking=off href="download.aspx?myID=11111111-2222-3333-4444-555555555555">Teet.docx</a></div>`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}