use strict;
my $str = '<a clicktracking=off href="https://www.test.com/1.pdf">test</a><br />Test<br />Test</div><br><div> </div><br><div><a clicktracking=off href="download.aspx?myID=11111111-2222-3333-4444-555555555555">Teet.docx</a></div>';
my $regex = qr/<a .*?href=(['"]?).*?\/?download.aspx\?myid=\{?([0-9a-f]{8}-?[0-9a-f]{4}-?[0-9a-f]{4}-?[0-9a-f]{4}-?[0-9a-f]{12})\}?\1.*?>(.*?)<\/a>/mip;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}