#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^-((?:(?:(?!{.*?})[^-\n]|{.*?})|(?:(?:(?!{.*?})[^-\n]|{.*?})*?-){2})*)-"
Local $sString = "-Hello everybody!- I'm here!" & @CRLF & _
"" & @CRLF & _
"-This {stuff} matches- here." & @CRLF & _
"-No match found {here-}." & @CRLF & _
"-But this last {hyphen-} works-" & @CRLF & _
"" & @CRLF & _
"-some -inner hyphens- inside- here." & @CRLF & _
"-some --inner hyphens- but the odd one outside -." & @CRLF & _
"-inner hyphens -inside- {braces-} -are- still ignored in this count- as usual-" & @CRLF & _
"-Hyphens both before- and after {the-braces} must be counted-" & @CRLF & _
"" & @CRLF & _
"-This is {fine-" & @CRLF & _
"-And so is this- here}" & @CRLF & _
"-----"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")