import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^-((?:(?:(?!\\{.*?\\})[^-\\n]|\\{.*?\\})|(?:(?:(?!\\{.*?\\})[^-\\n]|\\{.*?\\})*?-){2})*)-";
final String string = "-Hello everybody!- I'm here!\n\n"
+ "-This {stuff} matches- here.\n"
+ "-No match found {here-}.\n"
+ "-But this last {hyphen-} works-\n\n"
+ "-some -inner hyphens- inside- here.\n"
+ "-some --inner hyphens- but the odd one outside -.\n"
+ "-inner hyphens -inside- {braces-} -are- still ignored in this count- as usual-\n"
+ "-Hyphens both before- and after {the-braces} must be counted-\n\n"
+ "-This is {fine-\n"
+ "-And so is this- here}\n"
+ "-----";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}