#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "\bCAT-(17|19|20)\w*\b"
Local $sString = "CAT-17" & @CRLF & _
"CAT-19h" & @CRLF & _
"CAT-20j" & @CRLF & _
"CAT-20j23" & @CRLF & _
"CAT" & @CRLF & _
"CATERPILLAR" & @CRLF & _
"CAT-" & @CRLF & _
"CAT1" & @CRLF & _
"CAT-2"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")