package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`\bCAT-(17|19|20)\w*\b`)
var str = `CAT-17
CAT-19h
CAT-20j
CAT-20j23
CAT
CATERPILLAR
CAT-
CAT1
CAT-2`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}