re = /\bCAT-(17|19|20)\w*\b/
str = 'CAT-17
CAT-19h
CAT-20j
CAT-20j23
CAT
CATERPILLAR
CAT-
CAT1
CAT-2'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end