$re = '/\bCAT-(17|19|20)\w*\b/';
$str = 'CAT-17
CAT-19h
CAT-20j
CAT-20j23
CAT
CATERPILLAR
CAT-
CAT1
CAT-2';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);