package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?mi)MyValue\d{5,6}`)
var str = `MyValue12345 blah blah MyValue123456 blah MyValue222221`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}