re = /MyValue\d{5,6}/mi
str = 'MyValue12345 blah blah MyValue123456 blah MyValue222221'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end