package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`[A-Z]*(?: *[A-Z]+){4,}`)
var str = `This reges should capture repeated words WRITTENINUPPERCASEONEAFTERTHE other.
\*literal asterisks\*
Markdown provides backslash escapes for the following characters:
\ backslash
\` backtick
* asterisk
_ underscore
{} curly braces
[] square brackets
() parentheses
# hash mark
+ plus sign
- minus sign (hyphen)
. dot
! exclamation mark
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}