re = /[A-Z]*(?: *[A-Z]+){4,}/
str = 'This reges should capture repeated words WRITTENINUPPERCASEONEAFTERTHE other.
\\*literal asterisks\\*
Markdown provides backslash escapes for the following characters:
\\ backslash
` backtick
* asterisk
_ underscore
{} curly braces
[] square brackets
() parentheses
# hash mark
+ plus sign
- minus sign (hyphen)
. dot
! exclamation mark
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end