import re
regex = re.compile(r"[A-Z]*(?: *[A-Z]+){4,}")
test_str = ("This reges should capture repeated words WRITTENINUPPERCASEONEAFTERTHE other.\n\n"
" \\*literal asterisks\\*\n\n"
"Markdown provides backslash escapes for the following characters:\n\n"
" \\ backslash\n"
" ` backtick\n"
" * asterisk\n"
" _ underscore\n"
" {} curly braces\n"
" [] square brackets\n"
" () parentheses\n"
" # hash mark\n"
" + plus sign\n"
" - minus sign (hyphen)\n"
" . dot\n"
" ! exclamation mark\n")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")