// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"[A-Z]*(?: *[A-Z]+){4,}").unwrap();
let string = "This reges should capture repeated words WRITTENINUPPERCASEONEAFTERTHE other.
\\*literal asterisks\\*
Markdown provides backslash escapes for the following characters:
\\ backslash
` backtick
* asterisk
_ underscore
{} curly braces
[] square brackets
() parentheses
# hash mark
+ plus sign
- minus sign (hyphen)
. dot
! exclamation mark
";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}