import Foundation
let pattern = #"^(?P<io_device_name>[a-z|0-9]+)+\s+(?P<io_read_req_per_sec>\d+\.\d+)+\s+(?P<io_write_req_per_sec>\d+\.\d+)+\s+(?P<io_read_kb_per_sec>\d+\.\d+)+\s+(?P<io_write_kb_per_sec>\d+\.\d+)+\s+(?P<io_req_avg_wait_millisec>\d+\.\d+)+\s+(?P<io_req_avg_service_millisec>\d+\.\d+)+\s+(?P<io_bandwidth_utilization_percent>\d+\.\d+)"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
Device rReq_PS wReq_PS rKB_PS wKB_PS avgWaitMillis avgSvcMillis bandwUtilPct
loop0 0.00 0.00 0.00 0.00 0.00 0.00 0.00
loop1 0.00 0.00 0.00 0.00 0.00 0.00 0.00
loop2 0.00 0.00 0.00 0.00 0.00 0.00 0.00
loop3 0.00 0.00 0.00 0.00 0.00 0.00 0.00
loop4 0.00 0.00 0.00 0.00 0.00 0.00 0.00
nvme0n1 0.00 15.00 0.00 60.00 0.80 0.53 0.80
Device rReq_PS wReq_PS rKB_PS wKB_PS avgWaitMillis avgSvcMillis bandwUtilPct
loop0 0.00 0.00 0.00 0.00 0.00 0.00 0.00
loop1 0.00 0.00 0.00 0.00 0.00 0.00 0.00
loop2 0.00 0.00 0.00 0.00 0.00 0.00 0.00
loop3 0.00 0.00 0.00 0.00 0.00 0.00 0.00
loop4 0.00 0.00 0.00 0.00 0.00 0.00 0.00
nvme0n1 10.00 15.00 445.00 60.00 41.80 15.53 100.80
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)