#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(?<==)[^,\[\]]+(?=,)"
Local $sString = "{date=Tue Mar 30 00:00:00 BST 2021, minDate=Mon Mar 29 00:00:00 BST 2021, holidays=[], maxDate=Mon Jul 05 05:00:00 BST 2027}"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")