use strict;
my $str = '{date=Tue Mar 30 00:00:00 BST 2021, minDate=Mon Mar 29 00:00:00 BST 2021, holidays=[], maxDate=Mon Jul 05 05:00:00 BST 2027}';
my $regex = qr/(?<==)[^,\[\]]+(?=,)/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}