import re
regex = re.compile(r"(?<==)[^,\[\]]+(?=,)", flags=re.MULTILINE)
test_str = "{date=Tue Mar 30 00:00:00 BST 2021, minDate=Mon Mar 29 00:00:00 BST 2021, holidays=[], maxDate=Mon Jul 05 05:00:00 BST 2027}"
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")